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1. DOCUMENT CONVENTIONS 

The following icons are used as necessary to distinguish elements of text. 

 

NOTE. Notes emphasize additional information that may be useful to the 

reader. 

 

 

CAUTION. Describes a situation or practice that requires operator awareness or 

action in order to avoid undesirable consequences. 
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2. INSTALLATION INSTRUCTIONS 

2.1. SYSTEM REQUIREMENTS 

 Intel Pentium 4 or newer processor 

 Display resolution of 1024 x 768 or higher  

 Windows XP, Windows Vista or Windows 7  

 CD-ROM drive  

 512MB RAM or higher  

 USB or RS232 Port 

2.2. SOFTWARE INSTALLATION 

 Download the latest version of "GUI_Manager" software from 

http://www.tvielectronics.com and save it to your hard drive. 

 Unzip/extract "GUI_Manager.zip" to your hard drive. 

 From your hard drive, open “GUI_Manager.zip” and double click on “setup.exe”. 

 Follow the instructions on the screen to complete the installation. 

 To run the software, click on “Start”, navigate to “TVI Electronics -> GUI Manager” 

and then click on “GUI Manager”. 

2.3. SOFTWARE UNINSTALLATION 

TVI Electronics doesn’t supply an uninstaller program as part of the “GUI Manager” 

software installation package. The program can be removed using the Device Manager by 

simply right-clicking on the software and selecting "Uninstall". This will delete the 

associated registry entries and remove the program files. 

http://www.tvielectronics.com/
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3. GUI MANAGER USER GUIDE 

This guide describes how to use the GUI Manager software for evaluation of TFT LCD 

Controller Board. 

Figure ‎3-1: Startup Screen 

 

The Main Menu allows access to all the software current functions. 

 File Menu 

Communication: edits the communication settings. 

Exit: exits the software. 

 Tools Menu 

Font: programs fonts to the controller’s flash memory. 

Graphic (Image / Shape): allows previewing, saving and loading graphic patterns. 

Text: writes text on the target screen. 

Touch Screen: displays the touch screen options. 

Utilities: displays controller’s features. 

 Help Menu 

     About: displays the “About” screen. 

3.1. GUI MANAGER COMMUNICATION 

“Communication” utility (accessed from the “File” menu) is used to establish 

communication with the controller and set the communication (RS232) baud rate. 
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Figure ‎3-2: Communication 

 

A serial connection is required between the LCD controller board and PC in order to 

communicate with the controller. You can use a USB to serial converter if your PC 

doesn’t have a serial port or connect directly to a USB port.  

 
To establish a serial connection with the controller board: 

1. Select COM port. 

2. Select Baud Rate (default 115200). 

3. Press “Connect” button. 

 

 

Program will verify a physical connection with the controller. The selected COM 

port must exist in your PC and not be in use by another application. 

 

If connection is successful, the controller’s name, firmware and communication 

COM Port settings will be displayed. 
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Figure ‎3-3: Connection Successful 

 

Figure ‎3-4: Change Baud Rate 

 

In order to change the default baud rate: 

1. Bring up Communication utility (accessed from the “File” menu). 

2. Select your new baud rate value:  

9600, 14400, 19200, 28800, 38400, 57600 or 115200 bps (default) 

3. Press “New Baud Rate” button. 
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When Attention message appears, you must move jumper on J11 to a lower 

position (TC55343) or remove jumper on J9 (TC55149S) and click OK. 

 

4. The controller will automatically reset itself for the new settings to be 

active. The program will try to establish the communication with a 

controller using the new settings. 

 

 

The baud rate is stored and will default to the stored value. 

 

3.2. GUI MANAGER TOOLS 

The “Tools” utility is used to test the LCD controller’s commands. See controller’s 

User Manual for more information about the available commands. 

Figure ‎3-5: Tools Menu 

 

 

3.2.1. GUI MANAGER FONT 

“Font” utility (accessed from the “Tools” menu) is used to convert system 

fonts and to store them to the controller’s flash memory.  
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Figure ‎3-6: Font Utility 

 

The LCD controller supports 3 user-selectable fonts. The imported font size 

should not exceed the maximum character size, which is 48 pixels high. 

To convert a system font and then save it to the controller’s flash memory: 

1. Click on "Select Font" button, select font properties (name, style, 

size and effects) and then click OK.  

Figure ‎3-7: Font 
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Changing font color will not affect the LCD font.  

Underline and Strikeout effects are not supported with Italic font style. 

 

2. The selected font will appear in the preview window, as shown 

below. To save the selected font to the controller’s flash memory, 

select the font number (1 through 3) and click on "Capture" button. 

Figure ‎3-8: Font Preview 

 

 

3.2.2. GUI MANAGER GRAPHIC 

“Graphic” utility (accessed from the “Tools” menu) allows user to preview, 

save and load graphic patterns. 
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Figure ‎3-9: Graphic Utility 

 

 

3.2.2.1. GUI MANAGER IMAGE  

“Image” utility (accessed from the “Tools -> Graphic” menu) is used to 

save an Image to the controller’s flash memory. 

Figure ‎3-10: Image Utility 
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To select an image (*.bmp,*.jpg,*.gif) file from PC, click on "Open" 

button. The selected image will appear in the preview window and the 

image size will display. 

 

 

The Preview window is not resizable and depends on the controller’s 

version and screen’s orientation. 

 

To view a selected image file on the target display, click on "Preview" 

button. 

 

 

The 64Mbit of external flash memory is capable to save: 

TC55343 - up to 54 (320x240) screen images, 16 keypad icons (67x47 

pixels) and 10 icons up to 7920 pixels (for example: 90x88 pixels will 

equal to 7920 pixels). 

TC55149S - up to 43 (400x240) screen images. 

 

 

Figure ‎3-11: Image Utility - Load 

 

 

To load an icon from the external flash memory: 

1. Click on "Load -> Icon" to bring up Load Icon window. 
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Figure ‎3-12: Load Icon 

  
 

2. Select icon id number and location (X, Y coordinates) and then 

click OK. The selected icon will appear on the target display and 

the image size will display. 

 

 

The TC55149S controller doesn’t support icons. 

 

To load a screen from the external flash memory: 

1. Click on "Load -> Screen" to bring up Load Screen window. 

Figure ‎3-13: Load Screen 

  
 

2. Select screen id number and then click OK. The selected screen 

will appear on the target display and the image size will display. 
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Figure ‎3-14: Image Utility - Save 

 

To save an icon to the external flash memory: 

1. Click on "Save -> Icon" to bring up Save Icon window. 

Figure ‎3-15: Save Icon 

  
 

2. Select icon id number and then click OK. The selected icon will be 

saved to the controller’s flash memory. 

 

To save a keypad icon to the external flash memory: 

1. Click on "Save -> Keypad Icon" to bring up Save Icon window 

(Figure 5-16). 

2. Select icon id number and then click OK. The selected icon will be 

saved to the controller’s flash memory. 

 

To save a screen to the external flash memory: 

1. Click on "Save -> Screen" to bring up Save Screen window. 
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Figure ‎3-16: Save Screen 

  
 

2. Select screen id number and then click OK. The selected screen 

will be saved to the controller’s flash memory.  

 

Saving an image as Screen# 1 will replace a power-up screen. 

 

3.2.2.2. GUI MANAGER SHAPE 

“Shape” utility (accessed from the “Tools -> Graphic” menu) is used to 

add shapes to a screen. 

 

The selected color is represented in a 16 bit format. 

 

Figure ‎3-17: Shape Utility - Circle 

 
 
To add a Circle to a screen: 

1. Select "Circle" from the Shapes dropdown.  

2. Set the Circle properties: X, Y coordinates, R – radius and color.  

3. Select Draw for a circle outline. Select Fill for a filled circle.  

4. Click on "Set" button. 
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Figure ‎3-18: Shape Utility - Line 

 
 
 

To add a Line to a screen: 

1. Select "Line" from the Shapes dropdown.  

2. Set the Line properties: Start/End X, Y coordinates and color.  

3. Click on "Set" button. 

 

Figure ‎3-19: Shape Utility - Pixel 

 



 

15 
 

 
 

To add a Pixel to a screen: 

1. Select "Pixel" from the Shapes dropdown.  

2. Set the Pixel properties: X, Y coordinates and color.  

3. Click on "Set" button. 

 

Figure ‎3-20: Shape Utility - Rectangle 

 
 
To add a Rectangle to a screen: 

1. Select "Rectangle" from the Shapes dropdown.  

2. Set the Rectangle properties: Start (upper left corner) and End 

(lower right corner) X Y coordinates of the rectangle and color.  

3. Select Draw for a rectangle outline. Select Fill for a filled 

rectangle. 

4. Click on "Set" button.  

 

3.2.3. GUI MANAGER TEXT 

“Text” utility (accessed from the “Tools” menu) is used to write text on the 

target screen.  
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Figure ‎3-21: Text Utility 

 

 

To write text on the target screen: 

1. Set cursor position (X, Y coordinates), font color and click on "Set" 

button. 

2. Select the font number (1 through 3 or System) from the controller’s 

flash memory. 

3. Write your text in the preview window and then click Enter to send 

text. 

 

 

For custom fonts (1 through 3) the font will appear above the cursor 

position. The System font will appear below the cursor position. 

The selected color is represented in a 16 bit format. 

 

3.2.4. GUI MANAGER TOUCH SCREEN 

“Touch Screen” utility (accessed from the “Tools” menu) is used to test 

and calibrate the touch screen.  
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Figure ‎3-22: Touch Screen Utility 

 

The touch screen controller can operate in an XY Mode or a Keypad Mode.  

In XY Mode the controller will send raw XY coordinates of touch screen 

contact location.  

In Keypad Mode the controller will send digits to host microprocessor or 

PC.  

 

On touch release the controller will send “$” character (0x24). 

 

Controller Response: this will display the raw data sent from the 

controller.  

Coordinate: this will convert the raw XY data into coordinates.  

Key Pressed: if enabled, this will display the keypad ids. 

Touch Enable / Touch Disable: if enabled, this will configure the LCD 

controller to enable or disable the touch screen controller in an XY Mode. 

Keypad Enable / Keypad Disable: this will configure the LCD controller 

to enable or disable the touch screen controller in a Keypad Mode. 

Load Keypad / Unload Keypad: if enabled, this will load or unload the 

keypad and enable or disable the Keypad Mode. 
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The TC55149S controller doesn’t support Touch Enable, Touch Disable 

and Unload Keypad commands. 

 

In Keypad Mode the touch screen is divided into 16 rectangles (TC55343) 

or 12 rectangles (TC55149S). The controller will send ids of each 

rectangle, see Keypad Example. 

Example ‎3-1: 4x4 Keypad (TC55343) 

 
 

 

 

Example ‎3-2: 3x4 Keypad (TC55149S) 

  

Portrait             Landscape 

 

 

 

 

The TC55343 LCD controller uses two points calibration algorithm to 

calibrate the touch screen.  

The TC55149S LCD controller utilizes the AD7147 CapTouch™ controller to 

calibrate the touch screen. 

 

The Keypad rectangles will be populated with first 16 icons stored in the 

controller’s external flash memory. 

 

The provided templates can be modified with custom icons and stored in 

the controller’s external flash memory. 
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Calibrate: this will start the touch screen calibration.  

Follow the instructions on the screen to complete the calibration.  

 

 

There is no need to calibrate the touch screen every time the device is 

powered on. The calibration constants are saved in the controller’s 

memory and will be used after power on. 

 

3.2.5. GUI MANAGER UTILITIES 

“Utilities” (accessed from the “Tools” menu) is used to display controller’s 

features. 

Figure ‎3-23: Utilities 

 

Back Light ON / OFF: this will turn the LCD backlight ON or OFF. 

 

Screen Rotation 0° / 180°: this will rotate the screen to 0° or 180°. 

 

Screen Flip Horizontal / Vertical: if enabled, this will flip the screen 

horizontally or vertically.  

 

Screen Orientation Portrait / Landscape: if enabled, this will change 

the screen’s orientation to portrait or landscape accordingly. 

 

The screen’s rotation and orientation settings are saved in the controller’s 

memory and will default after power on. 
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Fill Screen: this will fill the entire screen with the selected color. Click on 

“Fill” button to process the command. 

Power Save ON / OFF: this will turn the LCD and backlight ON or OFF. 

 

 

The selected color is represented in a 16 bit format. 

 


